ODMR (On-Demand Mail Relay) Familie: Internetprotokollfamilie Einsatzgebiet: Abholung von E-Mail (Mail Transfer) Ports: 366/TCP 366/UDP Standards: RFC 2645 (1999) On-Demand Mail Relay (ODMR) oder Authenticated TURN (ATRN) ist eine Erweiterung für das E-Mail-Protokoll Simple Mail Transfer Protocol (SMTP). ODMR ist in RFC 2645 definiert.
ODMR ist ein E-Mail-Dienst, der es Benutzern erlaubt, nach entsprechender Authentifizierung ihre E-Mails bei einem Internet Service Provider (ISP) über dynamische IP-Adressen abzuholen.
Im Gegensatz zu POP3 wird die abzuholende E-Mail inklusive des SMTP Envelopes versendet, was für die Zuordnung zu einem Empfänger wichtig ist.
Der Client verbindet sich mit dem ODMR-Server und wird von diesem authentifiziert. Er fragt alle E-Mails für seine Domain ab. Danach tauschen Client und Server die Rollen, die E-Mails werden über die bestehende TCP-Verbindung per SMTP übertragen.
Diese Methode ist für Benutzer interessant, die keine permanente Internetverbindung haben, zum Beispiel für Benutzer mit einem ISDN-Wählzugang sowie für Benutzer mit wechselnden IP-Adressen, was z. B. auf viele ADSL-Angebote zutrifft.
ODMR-Server
ODMR-Server sind in manchen MTAs bereits integriert (z. B. ALT-N MDaemon), es gibt aber auch Erweiterungen für gängige Unix-MTAs wie Sendmail, Exim, Postfix und qmail.
ODMR-Client
Als ODMR-Client kann zum Beispiel fetchmail benutzt werden. Beispiel für eine Konfiguration in fetchmail:
poll odmr.mailserver.de proto odmr: user "benutzername" password "password" fetchdomains "domainname.de"
Bei Verwendung unter Unix ist hierbei wichtig, dass in /etc/services die Netzwerk-Ports konfiguriert sind:
odmr 366/tcp # odmr odmr 366/udp # odmr
sonst wird eine Socket-Fehlermeldung ausgegeben.
Kommandos
EHLO Das EHLO Kommando ist das gleiche wie in SMTP. Die Antwort des Client muss AUTH und ATRN enthalten. AUTH AUTH wurde in RFC 2554 definiert und mit RFC 4954 aktualisiert. Es benutzt einen SASL-Mechanismus, der in RFC 2222 definiert und mit den RFC RFC 4422 und RFC 4752 aktualisiert wurde. Die Sitzung wird als nicht authentifiziert betrachtet solange keine erfolgreiche Antwort zu AUTH gesendet wurde. Die Unterstützung von CRAM-MD5 ist für ODMR-Servern und Clients obligatorisch. ATRN Wenn der Client ATRN an den Server sendet, bekommt er für alle berechtigten Domains die E-Mails zugestellt. QUIT Dieser Befehl beendet die Sitzung.
Beispiel für eine typische ODMR-Verbindung:
> 220 EXAMPLE.NET on-demand mail relay server ready < EHLO example.org > 250-EXAMPLE.NET > 250-AUTH CRAM-MD5 EXTERNAL > 250 ATRN < AUTH CRAM-MD5 > 334 MTg5Ni42OTcxNzA5NTJASVNQLkNPTQo= < Zm9vYmFyLm5ldCBiOTEzYTYwMmM3ZWRhN2E0OTViNGU2ZTczMzRkMzg5MAo= > 235 now authenticated as example.org < ATRN example.org,example.com > 250 OK now reversing the connection < 220 example.org ready to receive email > EHLO EXAMPLE.NET < 250-example.org < 250 SIZE > MAIL FROM: <[email protected]> < 250 OK > RCPT TO: <[email protected]> < 250 OK, recipient accepted ... > QUIT < 221 example.org closing connection
Siehe auch SMTP-Relay-Server SMTP-Auth SMTP-After-POP ETRN
Weblinks
XATRN panozzo.it, ODMR-Client für Windows infinymail. ODMR-Server für Sendmail vodmr dcu.ie, ODMR-Server für vpopmail/vchkpw + qmail odmrd plonk.de, ODMR-Server für verschiedene MTAs (u. a. Exim, Postfix)
Einzelnachweise
Kategorie:Internet-Anwendungsprotokoll Kategorie:E-Mail