This is a partial list of RFCs (request for comments memoranda). A Request for Comments (RFC) is a publication in a series from the principal technical development and standards-setting bodies for the Internet, most prominently the Internet Engineering Task Force (IETF).

While there are over 9,963 RFCs , this list consists of RFCs that have related articles. A complete list is available from the IETF website.

__TOC__

Numerical list

# Title Date published Related article Made obsolete by Notes RFC 20 ASCII format for Network Interchange ASCII RFC 42 Message Data Types RFC 768 User Datagram Protocol UDP RFC 783 THE TFTP PROTOCOL (REVISION 2) TFTP RFC 1350 RFC 791 Internet Protocol IPv4 RFC 792 INTERNET CONTROL MESSAGE PROTOCOL ICMP RFC 793 TRANSMISSION CONTROL PROTOCOL TCP RFC 9293 RFC 826 An Ethernet Address Resolution Protocol ARP RFC 854 TELNET PROTOCOL SPECIFICATION Telnet RFC 855 TELNET OPTION SPECIFICATIONS RFC 862 Echo Protocol Echo RFC 863 Discard Protocol DISCARD RFC 864 Character Generator Protocol CHARGEN RFC 868 Time Protocol TIME RFC 903 A Reverse Address Resolution Protocol RARP RFC 937 POST OFFICE PROTOCOL - VERSION 2 POP v 2 RFC 951 BOOTSTRAP PROTOCOL (BOOTP) BOOTP RFC 959 FILE TRANSFER PROTOCOL (FTP) FTP RFC 1034 DOMAIN NAMES - CONCEPTS AND FACILITIES DNS RFC 1035 DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION DNS RFC 1036 Standard for Interchange of USENET Messages Usenet RFC 1055 A Non-Standard for Transmission of IP Datagrams Over Serial Lines: SLIP SLIP RFC 1058 Routing Information Protocol RIP v 1 RFC 1059 Network Time Protocol (version 1) specification and implementation NTP v 1 RFC 1087 Ethics and the Internet Internet Ethics RFC 1118 The Hitchhikers Guide to the Internet The Hitchhikers Guide to the Internet RFC 1119 Network Time Protocol (version 2) specification and implementation NTP v 2 RFC 1149 A Standard for the Transmission of IP Datagrams on Avian Carriers IP over Avian Carriers RFC 1157 A Simple Network Management Protocol (SNMP) SNMP v1 RFC 1176 INTERACTIVE MAIL ACCESS PROTOCOL - VERSION 2 IMAP v 2 RFC 1191 Path MTU Discovery PMTUD Obsoletes RFC 1063 RFC 1305 Network Time Protocol (Version 3) Specification, Implementation and Analysis NTP v 3 RFC 5905 Obsoletes RFC 1119, RFC 1059, RFC 958 RFC 1321 The MD5 Message-Digest Algorithm MD5 RFC 1350 THE TFTP PROTOCOL (REVISION 2) TFTP Obsoletes RFC 783 RFC 1436 The Internet Gopher Protocol Gopher RFC 1441 Introduction to version 2 of the Internet-standard Network Management Framework SNMP v 2 RFC 1459 Internet Relay Chat Protocol IRC RFC 1730 INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4 IMAP v 4 RFC 1777 Lightweight Directory Access Protocol LDAP RFC 1855 Netiquette Guidelines Netiquette RFC 1918 Address Allocation for Private Internets Private network RFC 1928 SOCKS Protocol Version 5 SOCKS5 RFC 1939 Post Office Protocol - Version 3 POP v 3 RFC 1945 Hypertext Transfer Protocol—HTTP/1.0 HTTP v 1.0 RFC 1948 Defending Against Sequence Number Attacks IP spoofing RFC 1950 ZLIB Compressed Data Format Specification version 3.3 Zlib v 3.3 RFC 1951 DEFLATE Compressed Data Format Specification version 1.3 DEFLATE v 1.3 RFC 1952 GZIP file format specification version 4.3 Gzip v 4.3 RFC 1964 The Kerberos Version 5 GSS-API Mechanism Kerberos; GSSAPI RFC 2080 RIPng for IPv6 RIP v ng RFC 2119 Key words for use in RFCs to Indicate Requirement Levels Request for Comments Updated by RFC 8174 RFC 2131 Dynamic Host Configuration Protocol DHCP RFC 2177 IMAP4 IDLE command IMAP IDLE RFC 2195 IMAP/POP AUTHorize Extension for Simple Challenge/Response CRAM-MD5 RFC 2228 FTP Security Extensions FTP RFC 2230 Key Exchange Delegation Record for the DNS Secure DNS RFC 2246 The TLS Protocol Version 1.0 TLS 1.0 RFC 2251 Lightweight Directory Access Protocol (v3) LDAP v 3 RFC 2252 Lightweight Directory Access Protocol (v3): Attribute Syntax Definitions RFC 2253 Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names RFC 2254 The String Representation of LDAP Search Filters RFC 2255 The LDAP URL Format RFC 2256 A Summary of the X.500(96) User Schema for use with LDAPv3 RFC 2326 Real Time Streaming Protocol (RTSP) RTSP RFC 2327 SDP: Session Description Protocol SDP RFC 2328 OSPF Version 2 OSPF RFC 2351 Mapping of Airline Reservation, Ticketing, and Messaging Traffic over IP MATIP RFC 2362 Protocol Independent Multicast-Sparse Mode (PIM-SM) PIM RFC 2397 The "data" URL scheme Data: URI scheme RFC 2407 Internet IP Security Domain of Interpretation for ISAKMP. IKE RFC 2408 Internet Security Association and Key Management Protocol (ISAKMP) RFC 2409 The Internet Key Exchange (IKE) RFC 2427 Multiprotocol Interconnect over Frame Relay Frame Relay 1294, 1490 RFC 2453 RIP Version 2 RIP v 2 RFC 2460 Internet Protocol, Version 6 (IPv6) Specification IPv6 RFC 8200 RFC 2549 IP over Avian Carriers with Quality of Service IP over Avian Carriers RFC 2555 30 Years of RFCsRetraces the history of RFCs RFC 2570 Introduction to Version 3 of the Internet-standard Network Management Framework SNMP v3 RFC 2595 Using TLS with IMAP, POP3 and ACAP STARTTLS for IMAP, POP3 and ACAP RFC 2606 Reserved Top Level DNS Names Fictitious domain name example.com, .test, ... RFC 2740 OSPF for IPv6 OSPF RFC 2743 Generic Security Service Application Program Interface Version 2, Update 1 GSSAPI v 2 RFC 2744 Generic Security Service API Version 2 : C-bindings RFC 2801 Internet Open Trading Protocol - IOTP Version 1.0Internet Open Trading ProtocolRFC 2802 Digital Signatures for the v1.0 Internet Open Trading Protocol (IOTP)April 2000Internet Open Trading Protocol RFC 2810 Internet Relay Chat: Architecture IRC RFC 2811 Internet Relay Chat: Channel Management RFC 2812 Internet Relay Chat: Client Protocol RFC 2813 Internet Relay Chat: Server Protocol RFC 2853 Generic Security Service API Version 2 : Java Bindings GSSAPI v 2 RFC 2865 Remote Authentication Dial In User Service (RADIUS) RADIUS RFC 2866 RADIUS Accounting June 2000 RFC 2935 Internet Open Trading Protocol (IOTP) HTTP SupplementInternet Open Trading Protocol RFC 2974 Session Announcement Protocol SAP RFC 3504 Internet Open Trading Protocol (IOTP), Version 1, ErrataMarch 2003Internet Open Trading Protocol RFC 3022 Traditional IP Network Address Translator (Traditional NAT) NAT RFC 3031 Multiprotocol Label Switching Architecture MPLS RFC 3053 IPv6 Tunnel Broker Tunnel Broker RFC 3056 Connection of IPv6 Domains via IPv4 Clouds 6to4 RFC 3080 The Blocks Extensible Exchange Protocol Core BEEP RFC 3162 RADIUS and IPv6 RADIUS (IPv6) RFC 3207 SMTP Service Extension for Secure SMTP over Transport Layer Security STARTTLS for SMTP RFC 3261 SIP: Session Initiation Protocol SIP RFC 3284 The VCDIFF Generic Differencing and Compression Data Format