The following tables compare general and technical information between a number of notable IRC client programs which have been discussed in independent, reliable prior published sources.
General Basic general information about the notable clients: creator/company, license, etc. Clients listed on a light purple background are no longer in active development.
Client Primary developers Distribution model Software license User interface Programming language Adium Thijs Alkemade Free software GUI Objective-C and C AmIRC Oliver Wagner, Nicolas Sallin, Costel Mincea Free software GUI ? BersircBersirc IRC Client - about Bersirc Jamie Frater, Nicholas Copeland Free software GUIC (Delphi originally) BitchX Colten Edwards Free software TUI, GUI C ChatZilla James Ross, Robert Ginda, Samuel Sieb, Gijs Kruitbosch Free software GUI JavaScript, XUL Colloquy Timothy Hatcher, Kiji Roshi Free software GUI Objective-C ERC Alexander L. Belikoff, Sergey Berezin Free software TUI, GUI Emacs Lisp HexChat Berke Viktor Free software TUI, GUIC Instantbird Florian Quèze Free software GUI C++, JavaScript, CSS, XUL ircII Michael Sandrof Free software TUIC Ircle Onno Tijdgat Commercial, 30-day trial GUIC Irssi Timo Sirainen Free software TUIC KVIrc Szymon Stefanek Free software GUIC++ Konversation KDE Free software GUIC++ LeafChat Samuel Marshall Free software GUIJava Linkinus Conceited Software Commercial, 15-day trial GUIObjective-C Mibbit Jimmy Moore Textual Adbar WebJavaScript frontend,Java backend mIRC Khaled Mardam-Bey Shareware, 30-day trial GUIC/C++ Nettalk Nicolas KruseFree software GUI Visual Basic Pidgin Free software GUIC PIRCH Northwest Computer ServicesShareware GUIDelphi PJIRC Philippe Detournay Free software GUIJava Quassel Manuel Nickschas, Marcus Eggenberger, Alexander von Renteln Free software TUI, GUIC++ rcirc Ryan Yeske Free software TUI Emacs Lisp Smuxi Mirco Bauer Free software GUI, TUI, serverC# Snak Kent Sorensen Commercial GUI ? Thunderbird Mozilla Foundation Free software GUI C, C++, JavaScript Visual IRC Jesse McGrew Free software GUIDelphi WeeChat Sebastien Helleu Free software TUI, GUIC XiRCON Mark Hanson Freeware GUI Borland C++, scripted with Tcl Client Primary developers Distribution model Software license User interface Programming language
Release A brief overview of the release history.
First public release First stable release Latest stable release Client Date Version Date Version AmIRC 1995 Bersirc 1999 BitchX 1996 ChatZilla 2001 Colloquy 2005 DMDirc 2007 ERC 1999? HexChat 2009-10-04 r249 2009-10-09 2.86.0 ircII 1989 2.0.0 1989 2.0.0 Ircle 1995 Irssi 1999 KVIrc 1998 0.6.0 1999-12-21 1.0.0 Konversation 2002 LeafChat ?1.0 Linkinus 2007 Mibbit 2008 web application, no version mIRC 1995 Nettalk 2004 PIRCH 1995 PJIRC 2002 Quassel 2008-08-27 0.3.0 rcirc ? ? Smuxi 2008-07-29 0.6 2010-09-03 0.8 Snak 1997 Visual IRC 1995 WeeChat 2003 Client Date Version Date Version Latest stable release First public release First stable release
Operating system support The operating systems on which the clients can run natively (without emulation). Client Windows 7, Vista XP, 2000 NT 4.0 NT 3.x Me, 98 95 3.1x ReactOS macOS (Intel/PPC) OS 9 OS 8 System 7 (PPC/68k) BeOS, Haiku OS/2, eCS, ArcaOS AmigaOS (68k) AmigaOS 4, MorphOS (PPC) DOS AmIRC Bersirc BitchX ChatZilla Colloquy ERC GNU Emacs has been demonstrated running in terminal mode on ReactOS via its Win32 console subsystem; this is unofficial and not documented by the Emacs or ReactOS projects. HexChat (2.9.5) ircII Ircle Requires OS X v10.4.3 or later Irssi Konversation KVIrc Connect to the ReactOS IRC Channels 2012-07-03: 4.2.0 Released! LeafChat Linkinus Mibbit mIRC Nettalk PIRCH PJIRC Quassel rcirc Smuxi Snak Visual IRC WeeChat Client Windows 7, Vista XP, 2000 NT 4.0 NT 3.x Me, 98 95 3.1x ReactOS OS X (Intel/PPC) OS 9 OS 8 System 7 (PPC/68k) BeOS, Haiku OS/2, eCS AmigaOS (68k) AmigaOS 4, MorphOS (PPC) DOS
Unix and Unix-like operating systems: Unix (BSD): 386BSD, BSD/OS, FreeBSD, NetBSD, OpenBSD, SunOS, ULTRIX Unix (System V): AIX, A/UX, HP-UX, IRIX, SCO OpenServer, Solaris, UnixWare Unix-like: Linux, NeXTSTEP, OpenVMS, OSF/1, QNX, Tru64 UNIX Client 386BSD BSD/OS (BSD/386, BSDI) FreeBSD, NetBSD, OpenBSD SunOS ULTRIX AIX A/UX HP-UX IRIX SCO OpenServer Solaris UnixWare Linux NeXTSTEP OpenVMS OSF/1 QNX Tru64 UNIX Bersirc BitchX ChatZilla Colloquy ERC HexChat ircII Ircle Irssi Konversation KVIrc LeafChat Linkinus Mibbit mIRC Nettalk PIRCH PJIRC Quassel rcirc Smuxi Snak Visual IRC WeeChat Client 386BSD BSD/OS (BSD/386, BSDI) FreeBSD, NetBSD, OpenBSD SunOS ULTRIX AIX A/UX HP-UX IRIX SCO OpenServer Solaris UnixWare Linux NeXTSTEP OpenVMS OSF/1 QNX Tru64 UNIX
Protocol support What IRC related protocols and standards are supported by each client.
Client IPv6 SSL TLS DANE OCSP CRL SASL OTR FISHLiM Bersirc BitchX ChatZilla Colloquy ERC HexChat ircII Ircle Irssi Konversation KVIrc Linkinus Mibbit mIRC Nettalk PIRCH PJIRC Quassel rcirc Smuxi Snak Visual IRC WeeChat Client IPv6 SSL TLS DANE OCSP CRL SASL OTR FISHLiM
Direct Client-to-Client (DCC) support The Direct Client-to-Client Protocol (DCC) has been the primary method of establishing connections directly between IRC clients for a long time now. Once established, DCC connections bypass the IRC network and servers, allowing for all sorts of data to be transferred between clients including files and direct chat sessions. Client CHAT SEND RESUME TSEND SEND T XMIT Passive DCC Server RDCC REVERSE RSEND Reverse / Firewall DCC File servers (FSERVs) XDCC VOICE Whiteboard Bersirc BitchX ChatZilla Colloquy ERC HexChat ircII Ircle Irssi Konversation KVIrc Linkinus Mibbit mIRC Nettalk PIRCH PJIRC Quassel rcirc Smuxi Snak Visual IRC WeeChat Client CHAT SEND RESUME TSEND SEND T XMIT Passive DCC Server RDCC REVERSE RSEND Reverse / Firewall DCC File servers (FSERVs) XDCC VOICE Whiteboard
IRCv3 support This software is compliant natively; other software may be compliant with extensions. Clients CAP CAP 302 Cap-notify Account-notify account-tag Away-notify batch Bot Mode chghost echo-message extended-join Invite-notify labeled-response message-tags Monitor msgid multi-prefix SASL v3.1 SASL v3.2 server-time setname sts userhost-in-names UTF8ONLY WHOX +typing draft/chathistory WebIRC draft/account-registration draft/extended-monitor draft/multiline +draft/react +draft/reply BitchX Colloquy HexChat 2.16 2.16 2.16 2.16 Irssi Git Git Git Git Git Git Git Git Git KVIrc Git Git Git Git Git Git Git Konversation v20.11.80+ v21.03.80+ v21.03.80+ v21.04.0+ Mibbit Mozilla Thunderbird 72.0+ 72.0+ 73.0+ 72.0+ 60.0+ Quassel IRC 0.14+ 0.14+ (opt in) 0.14+ 0.14+ 0.14+ 0.14+ WeeChat 2.2+ 2.2+ 2.2+ 3.3+ 3.3+ 3.3+ 3.3+ mIRC 7.62+ 7.62+
IRCv3 SASL mechanisms IRC SASL authentication primarily uses the same mechanisms as SASL in other protocols. Most commonly: PLAIN as defined by RFC 4616 EXTERNAL as defined by RFC 4422 SCRAM-SHA-256 as defined by RFC 7677
Client EXTERNAL PLAIN SCRAM-SHA-256 BitchX Colloquy HexChat Irssi KVIrc Konversation Mozilla Thunderbird WeeChat 3.2+ catgirl mIRC 7.68+ pydle(lib.) senpai zIRC(lib.)
Features Information on what features each of the clients support.
Client Multi-server UTF-8 Proxy server irc:// URI scheme Automatic updates Scripting language Bersirc BitchX Enhanced IrcII script ChatZilla JavaScript Colloquy AppleScript, Cocoa, F-Script, JavaScript, Python ERC Emacs Lisp HexChat Perl, Python, Tcl, Lua, JavaScript, C, C++, and via D-Bus. ircII IrcII script Ircle AppleScript Irssi Perl Konversation Shell script, Ruby, Python, Perl, Java, C++, C#, JavaScript KVIrc KVS (custom), Perl, Python, C++ LeafChat Java Linkinus AppleScript, Cocoa Mibbit mIRC mIRC script Nettalk SOCKS VBScript, custom PIRCH PJIRC Partial, JavaScript Quassel rcirc Emacs Lisp Smuxi (language agnostic) Snak AppleScript, IrcII script Visual IRC Versus WeeChat C, Perl, Python, Ruby, Lua, Tcl, Scheme (Guile) Client Multi-server UTF-8 Proxy server irc:// URI scheme Automatic updates Scripting language
See also Comparison of cross-platform instant messaging clients Comparison of user features of messaging platforms Comparison of instant messaging protocols Comparison of VoIP software List of SIP software Comparison of LAN messengers
References