This is a comparison of operating systems in regard to their support of the IPv6 protocol. OSVersionClaimed IPv6-readyInstalled by defaultDHCPv6ND RDNSSNotesAIX4.3AlliedWare Plus5.4.4Android4.1 (Jelly Bean)Support IPv6Support connecting to IPv6-only wireless networksSupport for DHCPv6 (RFC 3315)DHCPv6-PD (Prefix delegation only) support provided for Android 11 and newer will be available at the end of 2025 via a Google Play System Update.https://android-developers.googleblog.com/2025/09/simplifying-advanced-networking-with.htmlChromeOS67.0.3396.99Cisco IOS15.3Support for RDNSS option as of 15.4(1)T, 15.3(2)S.Cisco MerakiMR series 28.1 and laterDevices support DHCPv6 for clients but not for themselves.MX & MX seriesDevices can only carry/pass through IPv6 on bridge, but not route.Debian3.0 (woody)RDNSS support with "rdnssd" and "resolvconf" or "openresolve" packages.Fedora13FreeBSD9.0FreeBSD Handbook.FreeBSD 9.0-RELEASE Release Notes.FreeDOS1.3HP-UX11iIBM i7.1iOS4.1iPhone IPv6 Debugging Simplified with Ip6config — The IPv6 Experts.netJuniper JUNOS14.1RDNSS support introduced in JunOS 14.1LibreELEC9.2.1Mageia7+Mageia has had full support for IPv6 only and IPv4 + IPv6 since Mageia 7, as well as continuing to support IPv4 only systems.macOSMac OS X 10.7 (Lion)nanog: Mac OS X Lion has DHCPv6nanog: Re: Mac OS X 10.7, still no DHCPv6Versions 10.7 through 10.10 often prefer IPv4 even when working IPv6 connectivity is available.[RIPE Labs: https://labs.ripe.net/Members/emileaben/hampered-eyeballs Hampering Eyeballs - Observations on Two "Happy Eyeballs" Implementations] Versions 10.11 and up will prioritize IPv6 Traffic in spec with Happy Eyeballs.[IEEE Mailing List: https://www.ietf.org/mail-archive/web/v6ops/current/msg22455.html [v6ops] Apple and IPv6 - Happy Eyeballs]MeeGo1.2NetBSD7.0NintendoSwitch 17.0.1Switch 2 20.1.5OpenBSD6.6RDNSS is only supported for rad(8) so far. As of 6.6, OpenBSD still does not favor IPv6 connectivity if there is IPv4 connectivity.openSUSE42.1 (Leap)Release Notes for openSUSE Leap 42.1 .OpenVMS8.3PlayStation4 v3.505ReactOS0.4.14Though ReactOS itself has no IPv6 support, ReactOS Foundation services are all IPv6 enabled.Red Hat Enterprise Linux6IPv6 Ready Logo Program Approved List.Solaris11SUSE Linux Enterprise Server11Release Notes for SUSE Linux Enterprise Server 11.Symbian7.0Tizen (Smart TVs)1420.01622.4UbuntuAll supported versions RDNSS support available so long as NetworkManager uses IPv6 "Automatic" setting, otherwise "rdnssd" package required.webOS2.1.0Windows NT (includesWindows 10 Mobile, and Xbox One onwards)5.1 (XP)IPv6 Operating Systems.Windows XP users can use Dibbler, an open source DHCPv6 implementation. --update: Windows XP fully supports IPv6- but NOT IPv6 DNS queries (nslookup)6.x (Vista, 7, 8, 8.1), 10 RTM-Anniversary UpdateIPv6 Ready Logo Program Approved List.rdnssd-win32 provides an open source implementation of ND RDNSSrdnssd-win32|Free software downloads at SourceForge.net10 Creators Update and laterWindows 10 Creators Update introduces support for RFC 8106 (6106) RDNSS.Windows Mobile6.5If the OEM explicitly unsets the SYSGEN_TCPIP6 pre-processor symbol, the built image will not have any IPv6 capabilities.Windows Phone7.58(.1)Private lab research. No privacy extensions (RFC4941).z/OSV1R4.0z/VMV5R1.0z/VSEV4R2Via a third party TCP/IP stack, IP6/VSE from Barnard Software, Inc.

Notes Operating systems that support neither DHCPv6 nor SLAAC cannot automatically configure unicast IPv6 addresses. Operating systems that support neither DHCPv6 nor ND RDNSS cannot automatically configure name servers in an IPv6-only environment.

References

External links ISOC IPv6 FAQ with OS tips