This is a list of TCP and UDP port numbers used by protocols for operation of network applications. The Transmission Control Protocol (TCP) and the User Datagram Protocol (UDP) only need one port for bidirectional traffic. TCP usually uses port numbers that match the services of the corresponding UDP implementations, if they exist, and vice versa.

The Internet Assigned Numbers Authority (IANA) is responsible for maintaining the official assignments of port numbers for specific uses. However, many unofficial uses of both well-known and registered port numbers occur in practice. Similarly, many of the official assignments refer to protocols that were never or are no longer in common use. This article lists port numbers and their associated protocols that have experienced significant uptake.

Table legend + Legend of TCP and UDP table cells for port numbers Cell Description Described protocol is assigned this port by IANA, and it is: standardized, specified, or widely used on the port. Described protocol is not assigned this port by IANA, but it is: standardized, specified, or widely used on the port. Described protocol is assigned this port by IANA, but is not: standardized, specified, or widely used on the port. Described protocol is not assigned this port by IANA or standardized, specified, or widely used on the port. Port is reserved by IANA, generally to prevent collision after its previous assignment was withdrawn. The port number may be available for assignment upon request to IANA.

Well-known ports

The port numbers in the range from 0 to 1023 (0 to 210 − 1) are the well-known ports or system ports. They are used by system processes that provide widely used types of network services. On Unix-like operating systems, a process must execute with superuser privileges to be able to bind a network socket to an IP address using one of the well-known ports.. "... Port numbers below 1024 (so-called "low numbered" ports) can only be bound to by root ... Well-known port numbers specified by the IANA are normally located in this root-only space. ..."

+ Well-known ports Port TCP UDP SCTP DCCP Description 0 colspan=2 In programming APIs (not in communication between hosts), requests a system-allocated (dynamic) port 1 TCP Port Service Multiplexer (TCPMUX). Historic. Both TCP and UDP have been assigned to TCPMUX by IANA, but by design only TCP is specified. 2 colspan=2 De-assigned on 2025-02-13, previously compressnet 3 colspan=2 De-assigned on 2025-02-13, previously compressnet 5 colspan=2 Remote Job Entry was historically using socket 5 in its old socket form, while MIB PIM has identified it as TCP/5 and IANA has assigned both TCP and UDP 5 to it. 7 colspan=2 Echo Protocol 9 | colspan=2 || || Discard Protocol| || || || Wake-on-LAN 11 colspan=2 Active Users (systat service) 13 colspan=2 Daytime Protocol 15 Previously netstat service 17 colspan=2 Quote of the Day (QOTD) 18 colspan=2 Message Send Protocol 19 colspan=2 Character Generator Protocol (CHARGEN) 20 File Transfer Protocol (FTP) data transfer 21 File Transfer Protocol (FTP) control (command) 22 Secure Shell (SSH), secure logins, file transfers (scp, sftp) and port forwarding 23 Telnet protocol—unencrypted text communications 24 "any private mail system", often used for LMTP. 25 Simple Mail Transfer Protocol (SMTP), used for email routing between mail servers 27 colspan=2 nsw-fe (NSW User System FE) 28 Palo Alto Networks' Panorama High Availability (HA) sync encrypted port. 29 colspan=2 msg-icp (MSG ICP) 31 colspan=2 msg-auth (MSG Authentication) 33 colspan=2 dsp (Display Support Protocol) 37 colspan=2 Time Protocol 38 colspan=2 rap (Route Access Protocol) 39 colspan=2 rlp (Resource Location Protocol) 41 colspan=2 graphics (Graphics) 42 Host Name Server Protocol 43 WHOIS protocol 44 colspan=2 mpm-flags (MPM FLAGS Protocol) 45 colspan=2 mpm (Message Processing Module [recv]) 46 colspan=2 mpm-snd (MPM [default send]) 47 colspan=2 Removed by IANA on 2017-05-18, previously used for NI FTP. 48 colspan=2 auditd (Digital Audit Daemon) 49 colspan=2 TACACS Login Host protocol. TACACS+, still in draft which is an improved but distinct version of TACACS, only uses TCP 49. 50 colspan=2 re-mail-ck (Remote Mail Checking Protocol) 51 colspan=2 Historically used for Interface Message Processor logical address management, entry has been removed by IANA on 2013-05-25 52 colspan=2 Xerox Network Systems (XNS) Time Protocol. Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP. 53 colspan=2 Domain Name System (DNS) 54 colspan=2 Xerox Network Systems (XNS) Clearinghouse (Name Server). Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP. 55 colspan=2 isi-gl (ISI Graphics Language) 56 colspan=2 Xerox Network Systems (XNS) Authentication Protocol. Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP. 58 colspan=2 Xerox Network Systems (XNS) Mail. Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP. 61 colspan=2 Historically assigned to the NIFTP-Based Mail protocol, but was never documented in the related IEN. The port number entry was removed from IANA's registry on 2017-05-18. 62 colspan=2 acas (ACA Services) 63 colspan=2 whoispp (whois++) 64 colspan=2 covia (Communications Integrator (CI)) 65 colspan=2 tacacs-ds (TACACS-Database Service) 66 colspan=2 sql-net (Oracle SQL*NET) 67 Bootstrap Protocol (BOOTP) server; also used by Dynamic Host Configuration Protocol (DHCP) 68 Bootstrap Protocol (BOOTP) client; also used by Dynamic Host Configuration Protocol (DHCP) 69 Trivial File Transfer Protocol (TFTP) 70 Gopher protocol 71–74 colspan=2 NETRJS protocol 76 colspan=2 deos (Distributed External Object Store) 78 colspan=2 vettcp (vettcp) 79 Finger protocol 80 colspan=2 Hypertext Transfer Protocol (HTTP) uses TCP in versions 1.x and 2. HTTP/3 uses QUIC, a transport protocol on top of UDP. 81 TorPark onion routingBritton, T., Liu-Johnston, I., Cugnière, I., Gupta, S., Rodriguez, D., Barbier, J., & Tricaud, S. Analysis of 24 hours internet attacks. 82 | colspan=2 || || xfer (XFER Utility)| || || || TorPark control 83 colspan=2 mit-ml-dev (MIT ML Device) 84 colspan=2 ctf (Common Trace Facility) 85 colspan=2 mit-ml-dev (MIT ML Device) 86 colspan=2 mfcobol (Micro Focus Cobol) 88 colspan=2 Kerberos authentication system 89 colspan=2 su-mit-tg (SU/MIT Telnet Gateway) 90 | colspan=2 || || dnsix (DNSIX Security Attribute Token Map)| colspan=2 || || PointCast (dotcom) 91 colspan=2 mit-dov (MIT Dover Spooler) 92 colspan=2 npp (Network Printing Protocol) 93 colspan=2 dcp (Device Control Protocol) 94 colspan=2 objcall (Tivoli Object Dispatcher) 95 SUPDUP, terminal-independent remote login 96 colspan=2 dixie (DIXIE Protocol Specification) 97 colspan=2 swift-rvf (Swift Remote Virtual File Protocol) 98 colspan=2 tacnews (TAC News) 99 colspan=2 metagram (Metagram Relay) 101 NIC host name 102 ISO Transport Service Access Point (TSAP) Class 0 protocol; 104 colspan=2 Digital Imaging and Communications in Medicine (DICOM; also port 11112) 105 colspan=2 CCSO Nameserver 106 macOS Server, (macOS) password server 107 colspan=2 Remote User Telnet Service (RTelnet) 108 colspan=2 IBM Systems Network Architecture (SNA) gateway access server 109 Post Office Protocol, version 2 (POP2) 110 Post Office Protocol, version 3 (POP3) 111 colspan=2 Open Network Computing Remote Procedure Call (ONC RPC, sometimes referred to as Sun RPC) 112 colspan=2 McIDAS Data Transmission Protocol 113 | || || || Ident, authentication service/identification protocol, used by IRC servers to identify users| || || || Authentication Service (auth), the predecessor to identification protocol. Used to determine a user's identity of a particular TCP connection. 115 Simple File Transfer Protocol 117 colspan=2 UUCP Mapping Project (path service) 118 colspan=2 Structured Query Language (SQL) Services 119 Network News Transfer Protocol (NNTP), retrieval of newsgroup messages 123 Network Time Protocol (NTP), used for time synchronization 126 colspan=2 Formerly Unisys Unitary Login, renamed by Unisys to NXEdit. Used by Unisys Programmer's Workbench for Clearpath MCP, an IDE for Unisys MCP software development 135 | colspan=2 || || DCE endpoint resolution | colspan=2 || || Microsoft EPMAP (End Point Mapper), also known as DCE/RPC Locator service, used to remotely manage services including DHCP server, DNS server and WINS. Also used by DCOM 137 colspan=2 NetBIOS Name Service, used for name registration and resolution 138 NetBIOS Datagram Service 139 NetBIOS Session Service 143 Internet Message Access Protocol (IMAP), management of electronic mail messages on a server 151 colspan=2 HEMS 152 colspan=2 Background File Transfer Program (BFTP) 153 colspan=2 Simple Gateway Monitoring Protocol (SGMP), a protocol for remote inspection and alteration of gateway management information 156 colspan=2 Structured Query Language (SQL) Service 158 colspan=2 Distributed Mail System Protocol (DMSP, sometimes referred to as Pcmail) 161 Simple Network Management Protocol (SNMP) 162 colspan=2 Simple Network Management Protocol Trap (SNMPTRAP) 165 colspan=2 Xerox 169 colspan=2 SEND 170 colspan=2 Network PostScript print server 175 colspan=2 VMNET service using NJE 177 colspan=2 X Display Manager Control Protocol (XDMCP), used for remote logins to an X Display Manager server 179 Border Gateway Protocol (BGP), used to exchange routing and reachability information among autonomous systems (AS) on the Internet 180 colspan=2 ris 194 colspan=2 Internet Relay Chat (IRC) 199 colspan=2 SNMP Unix Multiplexer (SMUX) 201 colspan=2 AppleTalk Routing Maintenance 202 colspan=2 AppleTalk Name Binding 203 colspan=2 AppleTalk 204 colspan=2 AppleTalk Echo 205 colspan=2 AppleTalk 206 colspan=2 AppleTalk Zone Information 207–208 colspan=2 AppleTalk 209 Quick Mail Transfer Protocol 210 colspan=2 ANSI Z39.50 213 colspan=2 Internetwork Packet Exchange (IPX) 218 colspan=2 Message posting protocol (MPP) 220 colspan=2 Internet Message Access Protocol (IMAP), version 3 225–241 colspan=2 RFC 1060 249–255 colspan=2 RFC 1060 259 colspan=2 Efficient Short Remote Operations (ESRO) 262 colspan=2 Arcisdms 264 colspan=2 Border Gateway Multicast Protocol (BGMP) 280 colspan=2 http-mgmt 300 ThinLinc Web Access, Spartan protocol 308 Novastor Online Backup 311 macOS Server Admin (officially AppleShare IP Web administration) 312 macOS Xsan administration 318 colspan=2 PKIX Time Stamp Protocol (TSP) 319 Precision Time Protocol (PTP) event messages 320 Precision Time Protocol (PTP) general messages323 Resource Public Key Infrastructure 350 colspan=2 Mapping of Airline Traffic over Internet Protocol (MATIP) type A 351 colspan=2 MATIP type B 356 colspan=2 cloanto-net-1 (used by Cloanto Amiga Explorer and VMs) 366 colspan=2 On-Demand Mail Relay (ODMR) 369 colspan=2 Rpc2portmap 370 | colspan=2 || || codaauth2, Coda authentication server| || || || securecast1, outgoing packets to NAI's SecureCast servers 371 colspan=2 ClearCase albd 376 colspan=2 Amiga Envoy Network Inquiry Protocol 383 colspan=2 HP data alarm manager 384 colspan=2 A Remote Network Server System 387 colspan=2 AURP (AppleTalk Update-based Routing Protocol) 388 Unidata LDM near real-time data distribution protocol 389 Lightweight Directory Access Protocol (LDAP) 399 colspan=2 Digital Equipment Corporation DECnet+ (Phase V) over TCP/IP (RFC1859) 401 colspan=2 Uninterruptible power supply (UPS) 427 colspan=2 Service Location Protocol (SLP) 433 colspan=2 NNTP, part of Network News Transfer Protocol 434 colspan=2 Mobile IP Agent (RFC 5944) 443 colspan=2 Hypertext Transfer Protocol Secure (HTTPS) uses TCP in versions 1.x and 2. HTTP/3 uses QUIC, a transport protocol on top of UDP. 444 colspan=2 Simple Network Paging Protocol (SNPP), RFC 1568 445