vCard, also known as VCF ("Virtual Contact File"), is a file format standard for electronic business cards. vCards can be attached to e-mail messages, sent via Multimedia Messaging Service (MMS), on the World Wide Web, instant messaging, NFC or through QR code. They can contain name and address information, phone numbers, e-mail addresses, URLs, logos, photographs, and audio clips.
vCard is used as a data interchange format in smartphone contacts, personal digital assistants (PDAs), personal information managers (PIMs) and customer relationship management systems (CRMs). To accomplish these data interchange applications, other "vCard variants" have been used and proposed as "variant standards", each for its specific niche: XML representation, JSON representation, or web pages.
Overview The standard Internet media type (MIME type) for a vCard has varied with each version of the specification.RFC 6350, section 10.1 "Media Type Registration"
vCards can be embedded in web pages.
RDFa with the vCard Ontology can be used in HTML and various XML-family languages, e.g. SVG, MathML.
RFC 9554 Extensions defines several new vCard properties, namely CREATED, GRAMGENDER, LANGUAGE, PRONOUNS, and SOCIALPROFILE, and some new parameters for existing properties. It also updated the ADR and N properties to support more detailed addresses and secondary surnames respectively. The extension exists to align the same set of features between the JSContact and vCard formats.
Related formats jCard, "The JSON Format for vCard" is a standard proposal of 2014 in . RFC 7095 describes a lossless method of representing vCard instances in JSON, using arrays of sequence-dependent tag–value pairs. jCard has been incorporated into several other protocols, including RDAP, the Protocol to Access White Space Databases (PAWS, described in ), and SIP, which (via ) uses it to provide contact information for the operator of an intermediary which has rejected a call.
hCard is a microformat that allows a vCard to be embedded inside an HTML page. It makes use of CSS class names to identify each vCard property. Normal HTML markup and CSS styling can be used alongside the hCard class names without affecting the webpage's ability to be parsed by a hCard parser. h-card is the microformats2 update to hCard.
MeCard is a variation of vCard made by NTT DoCoMo for smartphones using QR codes. It uses a very similar syntax, but in a more consolidated way as the storage space on QR codes is limited. It's also limited in the amount of data that can be stored, not just by the standard but the size of QR codes.
Example
An example of a simple vCardFrom of August, 2011, abbreviated:
This is the vCard for "Simon Perreault" (the author of RFC 6350), with his birthday (omitting the year), email address and gender.
Properties vCard defines the following property types.
All vCards begin with BEGIN:VCARD and end with END:VCARD. All vCards must contain the VERSION property, which specifies the vCard version. VERSION must come immediately after BEGIN, except in the vCard 2.1 and 3.0 standards, which allows it to be anywhere in the vCard. Otherwise, properties can be defined in any order.
Name Property presence Description Example 2.1 3.0 4.0 ADR A structured representation of the physical delivery address for the vCard object. ADR;TYPE=home:;;123 Main St.;Springfield;IL;12345;USA AGENT Information about another person who will act on behalf of the vCard object. Typically this would be an area administrator, assistant, or secretary for the individual. Can be either a URL or an embedded vCard. AGENT:http://mi6.gov.uk/007 ANNIVERSARY Defines the person's anniversary. ANNIVERSARY:19901021 BDAY Date of birth of the individual associated with the vCard. BDAY:19700310 BEGIN All vCards must start with this property. BEGIN:VCARD CALADRURI A URL to use for sending a scheduling request to the person's calendar. CALADRURI:http://example.com/calendar/jdoe CALURI A URL to the person's calendar. CALURI:http://example.com/calendar/jdoe CATEGORIES A list of "tags" that can be used to describe the object represented by this vCard. CATEGORIES:swimmer,biker CLASS Describes the sensitivity of the information in the vCard. CLASS:public CLIENTPIDMAP Used for synchronizing different revisions of the same vCard. CLIENTPIDMAP:1;urn:uuid:3df403f4-5924-4bb7-b077-3c711d9eb34b CREATED The timestamp when the vCard was created. CREATED:20220705T093412Z EMAIL The address for electronic mail communication with the vCard object. EMAIL:[email protected] END All vCards must end with this property. END:VCARD FBURL Defines a URL that shows when the person is "free" or "busy" on their calendar. FBURL:http://example.com/fb/jdoe FN The formatted name string associated with the vCard object. FN:Dr. John Doe GENDER Defines the person's gender. GENDER:F GEO Specifies a latitude and longitude. 2.1, 3.0: GEO:39.95;-75.16674.0: GEO:geo:39.95,-75.1667 GRAMGENDER Defines the grammatical gender that the contact prefers to be addressed by or referred to as in written or spoken form. GRAMGENDER;LANGUAGE=de:feminine IMPP Defines an instant messenger handle.
This property was introduced in a separate RFC when the latest vCard version was 3.0. Therefore, 3.0 vCards might use this property without otherwise declaring it. IMPP:aim:[email protected] KEY The public encryption key associated with the vCard object. It may point to an external URL, may be plain text, or may be embedded in the vCard as a Base64 encoded block of text. 2.1: KEY;PGP:http://example.com/key.pgp2.1: KEY;PGP;ENCODING=BASE64:[base64-data]3.0: KEY;TYPE=PGP:http://example.com/key.pgp3.0: KEY;TYPE=PGP;ENCODING=b:[base64-data]4.0: KEY;MEDIATYPE=application/pgp-keys:http://example.com/key.pgp4.0: KEY:data:application/pgp-keys;base64,[base64-data] KIND Defines the type of entity that this vCard represents: 'application', 'individual', 'group', 'location' or 'organization'; 'x-*' values may be used for experimental purposes. KIND:individual LABEL Represents the actual text that should be put on the mailing label when delivering a physical package to the person/object associated with the vCard (related to the ADR property).
Not supported in version 4.0. Instead, this information is stored in the LABEL parameter of the ADR property. Example: ADR;TYPE=home;LABEL="123 Main St\nNew York, NY 12345":;;123 Main St;New York;NY;12345;USA LABEL;TYPE=HOME:123 Main St.\nSpringfield, IL 12345\nUSA LANG Defines a language that the person speaks. LANG:fr-CA LANGUAGE Defines the default language that human-readable text values in this vCard are assumed to be written in. LANGUAGE:de-AT PRONOUNS The pronouns that the contact chooses to use for themselves. PRONOUNS;LANGUAGE=en;PREF=1:he/herPRONOUNS;LANGUAGE=en;PREF=2:she/her LOGO An image or graphic of the logo of the organization that is associated with the individual to which the vCard belongs. It may point to an external URL or may be embedded in the vCard as a Base64 encoded block of text. 2.1: LOGO;PNG:http://example.com/logo.png2.1: LOGO;PNG;ENCODING=BASE64:[base64-data]3.0: LOGO;TYPE=PNG:http://example.com/logo.png3.0: LOGO;TYPE=PNG;ENCODING=b:[base64-data]4.0: LOGO;MEDIATYPE=image/png:http://example.com/logo.png4.0: LOGO;ENCODING=BASE64;TYPE=PNG:[base64-data] MAILER Type of email program used. MAILER:Thunderbird MEMBER Defines a member that is part of the group that this vCard represents. Acceptable values include:The KIND property must be set to "group" in order to use this property. MEMBER:urn:uuid:03a0e51f-d1aa-4385-8a53-e29025acd8af N A structured representation of the name of the person, place or thing associated with the vCard object. Structure recognizes, in order separated by semicolons: Family Name, Given Name, Additional/Middle Names, Honorific Prefixes, and Honorific Suffixes N:Doe;John;;Dr; NAME Provides a textual representation of the SOURCE property. NICKNAME One or more descriptive/familiar names for the object represented by this vCard. NICKNAME:Jon,Johnny NOTE Specifies supplemental information or a comment that is associated with the vCard. NOTE:I am proficient in Tiger-Crane Style,\nand I am more than proficient in the exquisite art of the Samurai sword. ORG The name and optionally the unit(s) of the organization associated with the vCard object. This property is based on the X.520 Organization Name attribute and the X.520 Organization Unit attribute. ORG:Google;GMail Team;Spam Detection Squad PHOTO An image or photograph of the individual associated with the vCard. It may point to an external URL or may be embedded in the vCard as a Base64 encoded block of text. 2.1: PHOTO;JPEG:http://example.com/photo.jpg2.1: PHOTO;JPEG;ENCODING=BASE64:[base64-data]3.0: PHOTO;TYPE=JPEG;VALUE=URI:http://example.com/photo.jpg3.0: PHOTO;TYPE=JPEG;ENCODING=b:[base64-data]4.0: PHOTO;MEDIATYPE=image/jpeg:http://example.com/photo.jpg4.0: PHOTO:data:image/jpeg;base64,[base64-data]RFC 6350 § 6.2.4, datatracker.ietf.org, https://datatracker.ietf.org/doc/html/rfc6350#section-6.2.4 PRODID The identifier for the product that created the vCard object. PRODID:-//ONLINE DIRECTORY//NONSGML Version 1//EN PROFILE States that the vCard is a vCard. PROFILE:VCARD RELATED Another entity that the person is related to. Acceptable values include: RELATED;TYPE=friend:urn:uuid:03a0e51f-d1aa-4385-8a53-e29025acd8af REV A timestamp for the last time the vCard was updated. REV:20121201T134211Z ROLE The role, occupation, or business category of the vCard object within an organization. ROLE:Executive SOCIALPROFILE The URI or username for social media profiles associated with the object the vCard represents. SOCIALPROFILE:https://example.com/ietf SORT-STRING Defines a string that should be used when an application sorts this vCard in some way.
Not supported in version 4.0. Instead, this information is stored in the SORT-AS parameter of the N and/or ORG properties. SORT-STRING:Doe SOUND By default, if this property is not grouped with other properties it specifies the pronunciation of the FN property of the vCard object. It may point to an external URL or may be embedded in the vCard as a Base64 encoded block of text. 2.1: SOUND;OGG:http://example.com/sound.ogg2.1: SOUND;OGG;ENCODING=BASE64:[base64-data]3.0: SOUND;TYPE=OGG:http://example.com/sound.ogg3.0: SOUND;TYPE=OGG;ENCODING=b:[base64-data]4.0: SOUND;MEDIATYPE=audio/ogg:http://example.com/sound.ogg4.0: SOUND:data:audio/ogg;base64,[base64-data] SOURCE A URL that can be used to get the latest version of this vCard. SOURCE:http://johndoe.com/vcard.vcf TEL The canonical number string for a telephone number for telephony communication with the vCard object. TEL;TYPE=cell:(123) 555-5832 TITLE Specifies the job title, functional position or function of the individual associated with the vCard object within an organization. TITLE:V.P. Research and Development TZ The time zone of the vCard object. 2.1, 3.0: TZ:-05004.0: TZ:America/New_York UID Specifies a value that represents a persistent, globally unique identifier associated with the object. UID:urn:uuid:da418720-3754-4631-a169-db89a02b831b URL A URL pointing to a website that represents the person in some way. Default = "homepage" URL;TITLE:https://www.johndoe.com VERSION The version of the vCard specification. In version 4.0, this must come right after the BEGIN property. VERSION:3.0 XML Any XML data that is attached to the vCard. This is used if the vCard was encoded in XML (xCard standard) and the XML document contained elements which are not part of the xCard standard. XML:<b>Not an xCard XML element</b>
See also CardDAV FOAF (ontology) Geo URI scheme
Notes
References
External links vCard 4.0 at its developer CalConnect describing extensions to vCard version 4 describing the vCard format version 4 RFC 2426 describing the vCard format version 3 vCard and vCalendar (old versions) from the Internet Mail Consortium in the Internet Archive